Iphone texture compression broken

So when I import a texture asset into Unity (iphone project) I get this:

Failed to execute /Applications/Unity/Unity.app/Contents/Tools/PVRTexTool

Failed to generate PVRT texture

UnityEditor.DockArea:OnGUI()

Every time, every project, every type of texture file. Completely fresh install of Unity (Pro + iOS trial). Mac OSX Snow Leopard.

I also tried replacing the PVRTexTool with one from their website, but it just gives the same error. Tried re-installning Unity again. No luck.

Uncompressed textures work though… and other compressions for other platform, but none of the iphone compression choices.

I am utterly stuck before I have even begin it seems. I am new to Unity on OSX…never had any similar trouble with Windows and Android though. Not exactly promising that this is the first thing that happens.

Anyone have any clue at all? Clearly it fails to execute the PVRTexTool… for some reason.

The problem was not with Unity, but with my OSX. Apparently I was missing the X11 addon that is required for PVRTexTool. After installing X11 from the Snow Leopard DVD compression now works as it should within Unity.

So if anyone else runs into this problem, check your utilities folder. If you dont have “X11” visible there, thats probably it.

I’m the same as Foxis… no solution! any other ideas people?