Is anybody else completely unable to use Unity?

Unity is currently running very choppy, around the 15-20fps mark inside the editor and also when running the game. This does not improve when exported or ran inside release mode. Unity used to run fine until recently when I updated it to 2018.3.11 and upgraded my GPU to the RX 570 8GB. Because I did both at the same time, it’s hard to isolate the problem. I’ve reverted back to old versions, but Unity now runs horribly regardless of which version I run, rendering all of my work useless. I tried completely uninstalling Unity Hub and all of the versions of Unity I had, then reinstalling it, but the problem still persists.

I checked task manager, and CPU usage is around 15%, with RAM usage around 40%. My PC is very powerful and can run all the latest games, applications, etc, on full settings at blazing fast speeds without any issues whatsoever. I ran the Profiler, and it says that it’s running at thousands of FPS (when disabling VSync), despite it running terribly. I also tried forcing Unity to open in OpenGL mode, but this has not affected its performance. All I can think is that maybe it’s trying to run on integrated graphics and not registering my GPU. However, my old laptop had a terrible GPU an it ran much better than this. Could it be fixed through the AMD control centre?

Lastly, the game is running at double speed. The movement of the player, enemies, props, projectiles, animations, etc, all seem to be sped up way faster than before, while drawing horribly choppy and laggily (if that’s a word) at the same time.

I am completely beside myself. I have absolutely no idea how to fix this issue. I’ve been trying for days and I’m at my wit’s end. Nobody seems to be able to supply an answer. I’ve extensively Googled this problem for hours at a time, asked all my friends, posted on forums, asked colleagues and more, but nobody can help me. I have a huge work assignment that needs doing within Unity, and if I can’t get the editor working properly then I’m finished.

Any help would be greatly appreciated. I’ll return the favour in any way I can, whether you need art resources, debugging, code, etc. Thanks in advance!

Hello @zuhane,

A similar problem happened to me recently. Unity started to lag and run at 15 fps, in editor mode, play mode, or even after releasing the game. I tried reinstalling, no success.

The problem came from an NVidia driver update that messed up with Unity. The best way to fix it is to simply purge the computer, by doing a full reset, to be sure the whole NVidia config and drivers are properly gone (I tried a full reinstall and it didn’t change anything, and same for downgrade NVidia drivers). Since you recently changed your graphic card, that might be the reason. It happened to me with a 1070 GTX, which of course could run anything but Unity after that issue.

Hope it helps

I have an old monitor which isn’t exactly good by today’s standards. The picture seems to overlap the edges of the screen, meaning I can’t see what’s happening in the edges. To resolve this problem, I used HDMI scaling in Radeon Settings to get the picture to line up correctly with the edges of the screen. However, doing so seems to tank the refresh rate of the monitor (for whatever reason), meaning that I have to either have a cropped monitor, or a fitting monitor that lags like hell. This, however, was being overridden in certain games and applications that seemed to force native 1920x1080 scaling, putting the frame rate back up to normal. Some applications ran without lag and some did - not really showing any discernible pattern that I could find, anyway.

This explains why windowed games and videos ran around 20fps, but full-screen got 100+. Anyway, seems like this issue can be fixed by changing the monitor settings or buying a new monitor. Hope this helps to anyone experiencing the same problem! :slight_smile: