Is ARKit compatible with 3D Spacial Blend Audio Source?

Hi everyone,

I have been using the ARkit for a while now and its amazing. I’m trying to integrate spacial audio into the AR experience and the App seems to not recognize when I set an Audio Source to Spacial Blend = 3D. Its weird because it works fine in the editor but when I run the App on the iPhone it always plays the audio track as 2D spacial Blend.

If anyone has any insights that would be great.

Thanks.

@elhongo Yes, it is. You may not have set “Spatial Blend” in Audio Source settings all the way to the right (3D). That should fix it.