Is automatic lightmap atlasing broken in Unity 4.0?

Since upgrading to Unity 4.0, the automatic lightmap atlasing process no longer packs the UV islands together efficiently. I create all my lightmap UVs outside of Unity and there is often empty space in the [0,1]x[0,1] UV square. The docs say this about it…

“If a UV set for a given object occupies only part of the [0,1]x[0,1] square, in many cases atlasing will move neighboring UV sets closer, to make use of the empty space.”

This worked fine in Unity 3.5 but no longer works for me in Unity 4.0. Is this known to be broken or am I doing something wrong?

Here’s a before and after…

5379-lightmapunity3.5.jpg
5380-lightmapunity4.0.jpg

Hello

I have the same issue, but whorse…

I make the UV2 of some meshes in maya, and when in unity 3.5 the atlasing for beast worked just fine.

But now I’m using unity 4, and with the same parameters I’ve got almost one LM for each object, with just a very small part in the texture used. So I’ve got more than 60 10241024 LM, with only 128128 pixels used sometimes. And for this object I’ve got the message “Object’s size in lightmap has reached the max atlas size”. Witch is obviously not the case when I look onto the lost of space in the LMs…

I’m having the exact same issue here and I’m surprised that fewer people are having this issue. Does Unity have any plans to fix this?

Worse here - no matter if Unity uv or custom. Always get an error described above. In 3.5 all scenes worked just fine.

This issue has apparently been fixed and should be in the next release (4.2). See this thread for details.