Is there a way to get URP working with Oculus Integration?

Unity Version: 2019.3.0f3

Okay, so for the last several months I have been trying to make a VR game in Unity. I want it to run fast and look good and so I have been using the LWRP or now URP. It worked great in the beginning but as more updates to Unity and the Oculus Integration have come out, I have been experiencing problems that should not be happening. Since my goal is to publish this app, I cannot use any other pipeline that comes installed with Unity, since it would take far too long for the app to open, meaning it could not be published.

Issues:

When built, the app will either: Not run at all and immediately go back to the library screen, get stuck on the three dot loading screen forever and then crash, or sometimes take a super long time to load and then only have one eye render.

Please help!
Thanks.

Only One Eye Rendering is solved by setting Single Pass in Project Player’s XR Settings

Also. ensure you’ve created a new UniversalRenderPipelineAsset and assigned that in your Project’s Graphics and Quality Render Pipeline settings