Is there a way to quickly tell if an asset in the asset store requires Pro

I don’t have Pro at this point in time, but I noticed that some assets say they require Pro version and some are proud that they work in both.

However, I don’t see anywhere ‘official’ (like a property on the asset page) that has the compatibility requirements. So, is there an easy way to tell?

You just rely on the description. There’s no flags or anything, especially since what’s available in Free vs. Pro can and does change from time to time. If the description doesn’t mention Pro, it would be safe to assume that it’s not required (otherwise the seller would have a lot of angry customers).