Is there a way to restore my lost project?

I tried to import a custom package to my Unity3.5

It turns out the package was meant for Unity 4.0

I got

Fatal Error: type == kMetaAssetType & pathName.find(“library/metadata”) != 0

and now I can even start unity… I get the splash screen and then this error.
Please help, I need to recover this project!

Well what you can do depends on several things:

  • What version of Unity are you curently using?
  • Do you have Unity pro?
  • Do you use metafile-serializing or the library folder in this project?

The only way is to remove the faulty files from your project manually.

First create a backup of the current state. Try to locate all files related to the package. If you don’t know where those files are, create a new empty project and open the package there. Don’t import it!!. Just take a look at the files and the relative folders to find the files in your actual project.

ps keep in mind that you can prevent Unity from loading your last project by holding the ALT key while starting up Unity. You have to press and hold it immediately after you started it.

I experenced same problem before.

This is how i solved it.

  1. Keep Unity Editor closed.
  2. Go to your project folder, and delete the plugin or other things you imported.
  3. Delete Library and Temp folders.
  4. Open up UnityEditor
  5. You may good to go.