Is there currently a problem with the relay server?

I made a small project to test the networking with matchmaker etc, it worked fine yesterday, but today i have a weird error:
Player A creates a match and is waiting for the other player

Player B loads the match list (the match is there), joines the match, i get get callback that the match was joined with sucess, but then nothing happens (the Server Player A doesn’t get any information / doesn’t spawn the network player) and Player B gets a debug log Log: cannot connect to relay server after 10 attempt to address, the disconnect method is called and then when i load the match list again it says that there is no match, but Player A still has the match and is still wating for the players

the same code worked yesterday with local pc’s and over the internet with friends, any idea why it doesn’t work today, is the relay server down?

I am experiencing the same issue. Happens both on 5.3.4 and 5.3.5. Tested with an old, known-to-be-working version of my game and still broken.