Is Unity 3.5 unstable/crashy (W7-64bit)

I downloaded 3.5 about 3 weeks ago and have been hacking around in my spare time - but my experience, thusfar, is that’s it’s dangerously unstable software you’d not want to work with and I’m wondering if it’s just 3.5, my OS or what???

I’m running W7-64 - I’ve noticed there appear to be a LOT of issues specific to that, but the problems I’ve been hitting are not minor and I’m wondering if others have seen the same stuff - such as

Several times (when dragging objects into scenes or moving stuff around, usually) I’ve had Scenes simple lose all their content (empty Hierarchy) - the only solution to this being to recover to an earlier backup (Dropbox has never been more useful)

I’m getting endless error messages about files being locked or in-use - I’ve tried running with Admin privs but that doesn’t help - and I suspect these messages may relate to the Scene corruption bug too??

I imported a Package into a project and existing (not imported) scripts started to behave weirdly. A script which had worked perfectly for days declared that it’s exposed (Inspector) variables were not set (they were - and I reassigned them and nothing changed - in fact that script now will not work at all!!).

I’m beyond frustrated with this - is this because I’m running on a 64bit W7, is this down to 3.5 being incomplete or do people put up with this utter nonsense??

Too often solutions on here appear to be ‘rebuild your scene’ or ‘recreate your objects’ - I’m sorry but I’m not going to spend dozens of hours only to have to redo huge amounts of work because the software is shoddy!?

Your experience is not shared by the beta testers, QA team or developers at Unity. It’s probably worth sharing your project with the QA team (by using the Bug Report feature in the editor.) They can then help you work out what is going wrong. Make sure you use the release version of Unity 3.5.0f5.

I’m using Windows 7 64-bit too and I’ve had very weird issues with Unity since I installed 3.5 release.!!

I just went back to 3.4.2, but what concerns me is people testing out my web builds who have 3.5 web player now are experiencing those issues.

UT is on it I’ve submitted a bug report but still waiting.

I have plenty of issues beside yours, and will revert to 3.4 for the time being.