is unity4.1.5 supports android 2.2 or 2.3 or 3?

i tried to build my game for android but unity says:

minimum platform for build is api 14 (android 4)

is unity 4.1.5 supports android 2.2 or 2.3 or 3?


According to what I’ve heard on Android Development Forum Threads you can…you just need to update your APIs…Lets hear it from Tseng,

Yep, the Build Target 4.0 is only required so Unity can use 4.0 features. But it still can be set to run on 2.1 devices.

The Build Target just tells which version of the framework to use. If you build against 3.2 Framework, you can only use features which are available up to 3.2. If you don’t use any features which are 2.1+ you can set your “minSdkVersion” to 2.1 (that’s the one you choose in Player Setting).

In classical Android environment it’s also possible to use reflection methods to look if a certain method of feature is available and dynamically add it. That’s probably what unity does. This keeps it 2.1 compatible and it’s still possible to use new features through reflections.

SOURCE : Android Development Forum Thread