Issue with ParticleSystem and transparency

Hello,

I have an issue with the transparency of particles. In the Editor, everything works as I want, meaning my particles are transparent around the edges, and it also works in Play to Device. However, in the build, I have a strange behavior where my transparency is replaced by white.

I should mention that I am currently using BakeToMesh but I also tried ReplicateProperties, ensuring that only compatible parameters are set in my ParticleSystem.

I have attached several screenshots. If anyone can help me, I would be very grateful.




Nothing jumps out at me as being wrong with your texture or material configuration. It looks like you’re getting alpha clipping behavior: in visionOS, when alpha clipping is enabled, any pixels above the alpha clip threshold are rendered as opaque. If it’s possible for you to submit a repro project as a bug report and let us know the incident number (IN-#####), we can look into it.

Indeed, it looks like alpha clipping …
I’ll make a blank project with this issue and submit it later on :slight_smile:
Thanks for your answer

1 Like