Issue with saving prefab parameters in Unity 3.5


I am experiencing a rather frustrating issue with the latest version of Unity that has completely halted all development.

Specifically there appear to be issues with saving the parameters of prefabs and scripts.
I first noticed the issue when I imported a package containing a script and a prefab (which had the script attached)

Any modifications I made to the parameters of the script attached to the prefab were lost upon shutting down unity.

I tried this with other prefabs of my own making and had no luck

I tried finding similar occurrences of the issue but all I found was this unsolved thread:

I have searched high and low for a solution but nothing works, I am at the end of my tether here. Anyone have any ideas or similar experiences? Is this a documented bug?

Thanks in advance!

I’d suggest a perpendicular approach to the problem.
Add a cube to the scene.
Add a new script to the project, and put any public variable in it.
Add the script to the cube, and change the variable.
Create a prefab out of the cube, exit unity, and see if it updates correctly.

Remove the troublesome script from the original prefab.
Put the new script in it, and do the same as with the cube.
If it works, it’s the original script’s fault, otherwise there’s something wrong with the prefab meta, which you might have to redo from scratch.