Ive spent 3 hours on this x.X

Ok so I am using the 000webhost thing and am trying to put up a game just to see if it works. This is my first time ever trying to get a game onto the web, and I am epicly failing. SO basically I'm using the SmartFTP client. I also have my html and unity file ready to upload. so from there under the first folder, I created a folder named "web_unity." I continued to up load my html and unity files. These are named:

Html file is~ “web_player.html”

Unity file is~ “WebPlayer.unity3d”

After this I got extremely lost. I am not sure how to link the file or whatever in my website. I also tried my:
www.websitename.site50.net/public_html/web_unity/web_player.html

I physicaly worte that into the URL and it only brought me to my homepage. so basically my question(s) are.

Should I have made the second folder (“web_unity”) to place my files into?

If the above answer is “It doesn’t matter.” then how do I access my Unity Game?

Also,if your answer is to delete everything else and only have the unity files in the “public_html” then how could I find a way around this. because I want a functional site, that you can browse through, then click the video game tab, and then click the link to the game which will let you play it.

My websites name is:

http://www.inkproductions-ringofstorms.site50.net/

If you click video game trails in the tab menu, you will see very little, with a link that says first test. In my mind, you click on it, then it should bring up the web_player.html file, and your gaming. But it just redirects you to the home page, and if you l ook at your URL, it says its ~

http://www.inkproductions-ringofstorms.site50.net/public_html/WebPlayer/WebPlayer.html

Instead of the regular hoem page of~

http://www.inkproductions-ringofstorms.site50.net/

Thanks for all of your guy’s help in advance!

Um, it doesn't matter where you put the files as long as they're out for the public.

You're problem is somewhere with the website.

My suggestion will be to find where you're index.php is and all of those and than put the WebPlayer.html there, and than try loading that,,, if it still doesn't work, its something from your website, hosting or what ever that automatically redirects you back to the homepage.

Maybe you have to rename your WebPlayer.html to index.html when stored in a seperate (not root) directory.

In your html code there is something like this:

if (typeof unityObject != "undefined") {
  unityObject.embedUnity("unityPlayer", "YourGame.unity3d", 1000, 600, params);
}

Check for the right name of the ".unity3d" file. It should be stored in the same directory as the html file.

Hey I'm not sure what I'm doing wrong, I have tried both suggestions, and neither worked. Is there a special way on how to link to the page? I'm am not an expert in html formating, only know the basics.

I found your web player html @ http://www.inkproductions-ringofstorms.site50.net/webplayer.html

Using the public_html in the path is making images not be found, i couldn't find the webplayer.unity3d file, so i would make sure it's located in the same folder/directory as the webplayer.html. Also on line 15:

unityObject.embedUnity("unityPlayer", "WebPlayer.unity3d", 600, 450);

is the literal name ("WebPlayer.unity3d") of the packaged unity 3d built, make sure that is in the same folder that the case is correct for the file name if it's there, some servers are case sensitive some are not.

hope that helps a little.

ok so I renamed it and thanks for finding that, your great, now is the 600,450) something important or is that just like the size of the Unity Preview Box?

Edit:

On a side note, i changed it and put it into its own folder, so you have to change ur url to this now.. http://www.inkproductions-ringofstorms.site50.net/unity/game1.html

Also, it is still not playing the game, I did rename the unity3d file, but it still just shows a download link for the Unity Web Player

Ok so I am still trying to figure out why this wont work, the Web page loads, but the game doesn't. Just has the link to download webplayer. Yes unity3d file is named correctly, and in same folder. Plz help:

http://www.inkproductions-ringofstorms.site50.net/unity/game1.html

i THINK i FIGURED IT OUT!!!!!!!!!!!!

go to the link I posted on the b4 answer and see if it works, what I did is i deleted all old files, re imported, I also imported the script that was with it, and now its working!