Jagged edges

Hi
I’m working on virtual gallery in unity3d. but i have a problem at first try:
My model in unity player has very jagged edges even in fantastic modes.
How could i reduce this issue on edges? should i increase segments in my model(built in 3dsmax)?
Thanks.

alt text

Turn on anti-aliasing in the quality settings.

I don’t know if this is going to help you, because you didn’t mention having materials on your objects, but if so, then I had the same issue for a few hours, when I made lamppost in blender, exported fbx. to unity and placed it, suddenly the only mesh that had jagged edges. ultimately my solution lied in the material, when I turn on smoothness up, ironically jagged edges pop up, and when I turn smoothness on material back down to 0, like magic, jagged edges gone. I really hope this helps someone, because I got a bit frustrated :smiley: good luck people!