Join Server only works on the same computer, join server does not work between 2 different computers.

I have 2 computers in the same house, on the same wifi. This is a recurring and EXTREMELY frustrating issue. I keep thinking I fixed it, but then I try to play with my brother and he says the join server button isn’t doing anything. Sure enough, I tried it and it doesn’t work for me either.

All I did was this code.

using UnityEngine;
using UnityEngine.UI;
using UnityEngine.Networking;
using System.Collections;

public class NetworkConnector : MonoBehaviour {
	
	public IPAddress ip;
	public IPAddress port;
	private bool isSetup;
	
	void Start () {
		StartCoroutine (Setup ());
	}
	
	void Update () {
		if (isSetup)
		{	
			if (ip.valid)
			{
				if (ip.textField.text != "")
				{
					NetworkManager.singleton.networkAddress = ip.textField.text;
				}
			}
			if (port.valid && port.textField.text != "")
			{
				NetworkManager.singleton.networkPort = int.Parse (port.textField.text);
			}
		}
	}
	
	public void StartHost () {
		NetworkManager.singleton.StartHost ();
	}
	
	public void StartClient () {
		if (ip.textField.text != "")
		{	
			NetworkManager.singleton.StartClient ();
		}
	}
	
	IEnumerator Setup () {
		yield return new WaitForSeconds (0.1f);
		isSetup = true;
	}
}

This is ridiculously frustrating and I have posted several questions but then taken them down, because I keep thinking it’s fixed but it’s not.

I can confirm the ip and port are being set, because the network manager is showing the changes from the input fields in the inspector. Do I have to type in the ip for both client and server? I’m doing that, but why can’t I connect? I’ve tried ports 1234 and 25000. I am using the ip 192.168.1.3 which is my server’s ipv4.

So I wanted to follow up.

It was indeed my firewall. Just a matter of figuring out what setting was blocking it. I made a unity exception and now it works. I wouldn’t quote myself though, because I’m almost paranoid now that it might reoccur. So I’m going to keep this answer unchecked just to test it some more. Thanks, Aidan.