Keyboard input not working

One day, when I got on to Unity, I tried to test my project out in the Editor. Everything worked fine- Except for the fact that suddenly, none of my inputs were working. To test if this was some other part of my code, I added a snippet which prints a message whenever I give a certain input in Update().

I found a problem exactly like mine, with no clear problems in the code. I think whatever was wrong with this guy’s Unity is wrong with mine, and I have no idea how to do what he did. Honestly, I just need to know how to get to the Input Registry he mentioned.

I am almost certain the problem is not in my code, but if somebody thinks I’m wrong, tell me.

if(Input.GetButtonDown("Interact") && distance < maxdistance){

In the AddItem function, I have Debug.Log(“Added Item!”). Just so people know.

Well, if you are sure that:

  • You defined a virtual axis called “Interact” …
  • Your “distance” is indeed smaller than “maxdistance” …
  • You’re executing this if-statement inside Update of an enabled script on an active GameObject in the scene while you’re in play-mode

…then… i have no idea.

I’ve checked my registry if that key exists (Win 8.1) but the there is no “Input” key under that path. If you want to check your registry, just press Win+R and type “regedit”. Navigate to the path mentioned in the post you’ve linked (HKEY_CURRENT_USER\Software\Unity\UnityEditor) and check if there is a string value called “Input”.

On my PC there’s only one string value and it’s called “Editor StatsDone” which is set to the string “yes”.

(ps: Just in case you didn’t know, don’t mess up anything in the registry or you might nuke your system, at least if you don’t know what you’re doing :wink: I strongly suggest to create a system restore point ;))

you can go to Edit/Project Settings/Input in unity thats were all your inputs are. have a look at em
maybe it have reset and stuff if that doesn’t work make a new project see if that helps.:smiley: :smiley:

Hello :!!!

I have the same problem… i try to learn Unity but during the tutorial “ball collecting object”… and after second chapter, I just realize that my keyboard dont control anything… the script i wrote for moving the ball is good but there is just no reactions when i launch the scene…
I try to take a look at my registry following your advice and i have two line in the unityEditor folder :
“Editor Statsdone”
and “(par défault)”
Doesnt seems to be the “listing” oooooooooooottt and bunny83 were talking about…

Also another info : i have install an older version of Unity 4.3.4 for another tutorial learning… and the keys are working !!!
HELP §§ I AM So lost… it’s working with the 4.3.4 but not with the 5.4.1