Keyring error

Hi there,
i recently installed unity hub in Linux lite 6, and receiving this error when i am running sudo apt-get update i tried to solve it by some online search help but not working for me.

Error: W: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

Thanks for any future help, i will be grateful.

Hey, I´ve just gone through the same error… and got the solution.

Since the apt-key is deprecated, you need to use gpg instead:

wget -o-

file public

gpg --no-default-keyring --keyring ./unity_keyring.gpg --import public

gpg --no-default-keyring --keyring ./unity_keyring.gpg --export > ./unity-archive-keyring.gpg

sudo mv ./unity-archive-keyring.gpg /etc/apt/trusted.gpg.d/

sudo apt update

sudo apt-get install unityhub

Basically, download the key, check the file, prepare to import the key, move the key, update the repositories, install the hub.




Thank you, this worked for me on Linux Mint 21.1

Thank you, this worked for me on Ubuntu 22

1 Like

thank you

still working thx !!!