Keytool not found,,,i am new to unity, please help

Hello to all friends here.
I am new here and this is my first post here.
I hope you will help me.
I am working on game and using unity for the first time.
I just got a single problem;
Keytool not found and so on,

I request you to please guide me to solve it.
As I told earlier, that I’m very beginner to development, so please guide me step wise and in detail, not only pro guide or tips.

Waiting for your response and thanks in advance.

For keytool may be you haven’t specified the CLASSPATH and PATH in the environment variables.

To set a classpath and path.Follow these stpes -

  1. From the desktop, right click the Computer icon.

  2. Choose Properties from the context menu.

  3. Click the Advanced system settings link.

  4. From the ‘Advanced’ tab Click Environment Variables. In the section User Variables, find the CLASSPATH environment variable and select it. Click Edit. If the CLASSPATH environment variable does not exist, click New.

  5. In the Edit User Variable (or New User Variable) window, specify the value of the CLASSPATH environment variable.

  6. Enter “CLASSPATH” in variable name and copy following path in variable value.

variable name = CLASSPATH

variable value = “C:\Program Files\Java\jdk1.7.0_45\lib”

  1. Again add new Environment Variable and set name as PATH and copy following path as variable value

variable name = PATH

variable value = “C:\Program Files\Java\jdk1.7.0_45\bin”

  1. Then click OK. Close all remaining windows by clicking OK.

  2. And then restart Unity.You’ll get your keytool.

For anyone reading this in 2018 or later: Unity runs a background process called “Unity Hub” that will not pick up path changes unless you kill and restart Unity Hub.

So, before doing @Niks4Linux 's answer, click the ^ icon in the task bar, find Unity Hub, right click, Quit Unity Hub.

You can also do this via Task Manager, More Details, Processes, Background Processes, and End Task on Unity Hub.

Change the path variables, then restart Unity, and the error will go away.

i follow step by step process but not work

NOT worked for me :frowning: now i have NOTHING in Android Build Facebook Settings

Worked for me!!! Thanks so much @Niks4Linux