Killing Object Not working as it should be...

Scene ‘Assets/level!.unity’ (-1) couldn’t be loaded because it has not been added to the build settings or the AssetBundle has not been loaded.
To add a scene to the build settings use the menu File->Build Settings…
UnityEngine.SceneManagement.SceneManager:LoadScene(String)
UnityStandardAssets._2D.Restarter:OnTriggerEnter2D(Collider2D) (at Assets/Standard Assets/2D/Scripts/Restarter.cs:13)
Got the problem after saving scene. Everything b4 saving was going right. my character is passing through killing object without restart. please help.

You’re probably writing the scene name wrong. I guess your scene is called “level” but you’re passing " level!" (note the ! at the end) to the LoadScene method.

That, or you forgot to add the level! scene in build settings or removed it by mistake.