Left eye not rendering when setting Direct Render flag to false - iOS / Cardboard SDK

I’m trying to apply filters to my Cardboard cameras to achieve blur effects etc.

Applying the effects whilst Direct Render is turned on (default) causes one image to be rendered across both eyes. I’ve read a couple of posts suggesting to turn off Direct Render to fix the issue.

This works great for Android and renders perfectly. However, on iOS I’m just getting one eye rendered correctly, and the other is just black (see attached).

I’ve searched high and low and can only find brief references to similar problems. Is this a general bug, or something odd in my set up? Anyone got any ideas? It’s driving me mad.

Unity 5.3.1f1 Personal

Cardboard SDK v0.6

iPhone 6 running iOS 9

Xcode 7.2


Can you specify your effect setup (which effects, settings, etc)? I can try to replicate locally to figure this out.

I am experiencing the same issue, Unity 5.2.2, Cardboard SDK 0.5.2, iPhone 6 and iOS 9.

Turning off Direct Render and HDR on Left and Right Camera causes only right eye to render. Switching to OpenGL does fix it for me as well, but FPS hit leaves that as undesirable.

@Dolims thanks that worked for me.

I had similar problem.
I used Bloom Image Effect, 0.7 Cardboard SDK version and Unity 5.3.4f1.
Only turning off “Multithreaded Rendering” in Player settings worked for me.

I had the same issue, using blur effect with ‘Multithreaded rendering’ setting enabled caused only one camera to render. Upgrading to Unity 5.4.0f2 solved the problem.