Lens flare not showing up

Why aren’t lens flares working!?

  • My camera has a flare layer
  • My camera has the flare layer turned on
  • The lens flare is positioned in front of the camera, about 20 units away
  • The lens flare is NOT attached to a light, but rather is attached to an otherwise empty object
  • The lens flare has directional unchecked
  • The object is on default layer
  • The lens flare is set to ignore nothing
  • The camera’s far plane is 1000, so the flare is in view
  • The flare is perfectly viewable in the scene view
  • There are no objects between it and the camera, let alone colliders
  • The flare has a texture, and it’s bright enough
  • I’ve tried attaching the flare to a point light as well

The flare works fine in the scene view, but not in the game view.
What’s going wrong!?

EDIT: Another odd thing is that in older projects where the flares used to work, they don’t anymore. This also happens with GUIText. This is a very strange problem.

Ok, I fixed it :

simply think to add the lens layer on each Oculus camera.

Just wanted to add this for anyone who isn’t adept at code.

Add component > Flare layer, to each of the three ovr cameras, ‘Left eye anchor’ right eye anchor’ and ‘centerEyeAnchor’.

Might be a bit basic for this thread but thought it might help someone.

Perhaps they are fixed problem already,
but possibly my answer helpful for somebody come from google.

I encountered same problem, but only few flares (e.g. “Sun(from space)” and “Laser” in standard assets) worked. common point on these is “Use Fog” property on .flare assets.

other few flares also be works when “Use Fog” property checked out.
but still few flares (e.g. Subtle1,2,3) seems not work ever.

In my case, not showed both (scene view and game view) when use no showing flares.
therefore may be not same cause for original poster, but few case on same problem, perhaps clue of cause is related fog properties?

Whenever I do flares I add a point light and select a flare form the flare menu.