level doesn't work after reloading

Im having issues with a puzzle game i am working on. it functions similar to minesweeper.

The numbers on the columns and rows indicate the amount of bombs and points there are.
So when i load the scene from the Mainmenu scene the first time after starting the game in the editor, it works fine. Win or lose, it brings you back to the main menu, when you go to to retry the level, the following image happens

On the second attempt, the text doesn’t update to show the updated text for the bombs/points

[EDIT: 1/27]
After testing, it looks to be the box colliders on the columns/rows aren’t detecting collisions (bombs and points that get spawned) after the scene is reloaded,

I have tried using OnTriggerEnter and OnTriggerStay, i tried using Rigidbody/BoxCollider as well as Rigidbody2D/BoxCollider2D and none of those worked.

That’s what is weird, no errors are coming up. i did originally use a static variable to keep track of info different objects had to pull from (ie: number of rows/column based on difficulty picked), but when i found out that static variables have only one global instance, i thought info could be left over after playing round one. I updated my code to remove the static variables and fix the references to them but still get the same issue.

is the main menu another scene or you’re loading it in the same level scene?
and what does the retry button actually do? I imagine it should just load the level scene