Lighting is wrong unless native resolution is used

Everything becomes dark, for all scenes. Like a filter on top. I’ve read about auto bake and I don’t think that is my issue. It seems related to resolution/aspect ratios. I cannot grasp it.

What I’ve established is:

  • It appears when running fullscreen (non-exclusive) in any non-native resolution. The native resolution is the only one not showing the problem.
  • It does not appear when I use gamma color space (but this changes lighting fundamentally so it may be unrelated).
  • It does not appear when I set fullscreen to exclusive mode (DX11, but then vsync fails and I get horrible tearing).
  • It does not appear in windowed mode.

I have auto bake disabled. I’ve cleaned and rebaked all scenes many times but this makes no difference.

Does anyone have any clues about this? If anyone is willing to help I’m happy to provide more information.

Here’s two images for comparison. Both are in a non-native resolution and the second one shows the problem. The only difference between them is the first one runs exclusive fullscreen, the other one does not.

No problem


Thankful for any input!

One thing I notice in the unity docs here Unity - Manual: Color space

Even though the desktop platforms generally support linear rendering, in some cases it may be disabled due to graphics driver issues. You can check this by looking at QualitySettings.desiredColorSpace and QualitySettings.activeColorSpace. If the desired color space is linear but the active color space is gamma then the player has fallen back to gamma space. This can be used to inform the user that the application will not look correct for them or to force an exit from the player.

@isbeorn what happens if you check QualitySettings.activeColorSpace?

And does updating drivers fix this issue for you?

We’re having this issue on our 4k test machine; still doing tests to see what’s happening.

I have same issue on Unity 2018.4.31.