Lightmap patchiness: dark patches

Please Help!
Looks fine with 1 real time point light

Change it to baked and I get this:

This is the baked view in case it helps.

Have tried all sorts of settings - really stuck! (Used to bake lightmaps in old days for q3 engine, no problems, this just seems random!)

Things that helped in order of effectiveness for my particular case

  1. Reducing Hard Angle from default 88 to 75 ish
    (Model Import Settings, under Advanced (under Generate Lightmap UVs))
  2. Upping Pack Margin (Again Model Import Settings, under Advanced (under Generate Lightmap UVs). tried upping default 8 to 32
  3. Upping Pushoff from default 0.0001 to 0.01 (LightMapParameters (Under Lighting window, Scene, General GI. Click on Default Parameters, and Create New. Click Edit to change)
  4. Upping Scale in Lightmap for the object can help reduce seams
  5. Upping baked resolution 80/120 started to remove seams between sections