Lightmapping - Increase Resolution

I’m trying to increase the overall resolution in my scene for my lightmapping, but it seems to make no difference after about a resolution of 3?

I have ‘Show Resolution’ checked in my editor, so I can see the checkered res on all my models, I really want my shadows to be as detailed as possible, but increasing the res after 3 doesn’t effect my lightmaps at all.

Also, I can see that some models have a higher res than others: (this is on a res of 3)


Surely this means that the shadow size will be inconsistent? How would I get all the res balanced and increase it to the max?


I believe you can do this by opening the Lightmapping tab (Window>Lightmapping), then selecting an object with a MeshRenderer (or similar) attached, and changing the value in the “Scale In Lightmap” option. You can’t increase lightmap resolution arbitrarily, though, since most graphics cards can’t support textures larger than 4096x4096, and some can’t support textures larger than 2048x2048, so you’ll have to scale the resolution down if you want it all to match. In practice, you don’t have to keep it incredibly consistent, especially if the shadows on different objects aren’t touching, or the shadow is small. The size of the shadows will be unaffected, it’s only the resolution, so unless there is a huge resolution difference, it won’t be noticeable to the naked eye.

Increasing the lightmap texture resolution (to 4096x4096), then scaling down the relative resolutions using the Scale In Lightmap option, is the best way to achieve high quality, consistent shadows across your scene. Unity, by default, caps the lightmap atlas size to 1024x1024, but you can get around this.

I hope this helped, if not the original poster (since this is a few months old), anyone else having the same issue.