Lightmapping strange behaviour


I’m having some problems with Beast’s lighmapping results. For example, in this case the house should be completely covered by a shadow, however it is illuminated on the shadow contours of a near tree (from terrain).

This is possibly hard to explain in words so I have included 2 images:

Wrong Lightmapping
Wrong Lightmapping

View from the base of the house
View from the base of the house

Do any of you know how to fix this?
Thanks in advance

all right after fiddling around with it for around 4 hours and used up my sparetime for today, the best solution I came up with for this kindda scenario:

1.Clone/duplicate your BigTree prefab and rename it to something like BigTree_without_shadow

2.Go into the BigTree_without_shadow and disable the static box, so it wont be lightmapped

3.Go further down and disable the cast shadow boxes, for the prefab if needed also separately for the leaves and the bark.

4.This tree You will have to drag & drop one at a time into your scene those places with that kind of problem, where you dont want it to cast that funky shadow.

5.You need to delete the tree youve added through the terrain tree painter and put this one their instead and it will not cast a caustic like shadow mix in your shadow areas.

I have also taken a quick screenshot of the scene, and where to turn off the shadow props and lightmapping for that object, i modified the scene a bit too, to debug of course if their was something wrong with the terrain or similar.

Yeah I know the tree will be missing a shadow but, if you keep those areas high enough or surround by colliders so the player wont be able to go there, than their shouldn’t be any problems.

Yeah Agree that it is a problem due to Beast lightmapper, but for now this is the only solution i can come up with, so why wait for extension of the beast lightmappers preferences, which will not come anytime soon.

screenshot: ImageBam

alt text

Enjoy! This is the solution i will be using in my project, for now, when I run into this problem, which I havent for now.

increase your lightmapping resolution to minimum 50, looks like its below 50 on your SS