Lightmapping terrain WITHOUT trees

Hello, I have a rather interesting problem.

I have a heavily wooded scene (in a forest, if you must know). I’m only using Unity Free, so I have no real-time shadows. I’m working by lightmapping the entire scene, and using projectors for basic shadows on moving parts. My issue is that, because of the number of trees in the scene, many objects don’t get a shadow cast under them, because they are already in shadow thanks to the tree above them. I thought that a potential way of fixing this might be to create two lightmaps - one for just trees, and one for everything excluding trees - and then merge the two manually. This would create lightmaps that have visible shadows even if the entire object is eclipsed by a tree, and thus prevent it from looking really odd, as it does now.

My problem is that, after attempting to bake the scene with the trees disabled, the lightmap still cast their shadows, despite them being disabled in the terrain settings. I want to know if there is a way to get rid of trees temporarily, or exclude them from the light mapping process, so I can achieve this. So far, everything has just come up empty.

I eventually achieved this by making a “blank” prefab, that was just a transform with no renderer. I then replaced all the tree prefabs with this, baked the lightmap, and then restored the original trees. All sorted now!