Lightmaps baking problem

Previously when i bake 2 light maps were being generated but now whenever i bake 74 light maps are being generated :confused: When am in the lightmapping tab, i go on Maps and change the arraySize to 2(cause i want 2 lightmaps) but When i bake again 74 lightmaps are still being generated.
Is there a way to bake more effectively, or solve this issue?

The lightmapper decides on its own how many lightmaps would be the best amount! Presumably, you’ve turned the ‘texels per world unit’ value up at some point, and all of a sudden all your lightmaps no longer fit on two 1024 x 1024 sheets. Remember, you only have so many pixels on every texture!

one solution might in fact be the texels per world unit count, which you modify under the lightmap window, at the bottom.
check out the documents here.

Another solution could be the Scale in lightmap count, which is in the lightmap window but in the object tab.

A third solution could be, but this is farfetched, since I haven’t seen your scene, that you have lots and lots of objects in your scene. Remember that Beast renders each object for itself, even if it’s an instance of a prefab.
My solution to that is to disable all the prefab instances, except for one, and launch the baking. Afterwards, re-enable the instances and revert them to the baked prefab state.

Hope that was useful (and not too late)

this will help you all to bake prefeb and use it run time