Lights after baking

Why my lightmaps look so awful after I bake the static lights

As you can see from the picture, those waves that are coming from the light. Can you please tell me how to fix that?.

Thank you in advance

These are the settings

In maps tab, try to uncheck compressed option, after this the size of your lightmaps will increase but the waves might be gone.