Line showing at the top of my tall grass

I made some tall bullrushes for a swap I was working on but at the top of the bullrushes there is a line that appears. It’s NOT in the actual PSD file, I’ve cropped it, re cropped the image, checked, double and event tripple checked the B&W alpha channel so It’s DEFINITY NOT IN MY IMAGE FILE… can’t stress that enough.
So Why Oh why am I getting this annoying line at the top of my grass/bullrushes?
I’ve tried everything I can think of to try and get rid of it?

There’s an answer somewhere around here that explains how Unity combines all the grass textures, and maybe some more stuff, into one big texture. Due to the way sampling works, the now former edge pixels are affected by adjacent pixels, which now come from the edge of other textures. I assume that Unity assumes all but the bottom pixels of grass are transparent, when it arranges them into the atlas.

This packing usually works pretty well, but, for example, if you toss an opaque green square into your grass textures, it jams up other grasses – I had left/right edge problems, and moving around other grass changed the error, then fixed it. To verify, try your grass texture in a stripped-down demo project, it should look fine.

Turn on clamping for your grass texture. It’s as simple as that.

The reason you see a line is because Unity generates mipmaps for textures, and as you get farther away from the grass, it downsamples to a lower resolution texture. This blurs the edges a bit and causes wrapping.

You can disable wrapping by clamping your textures:

It’s not your image file. Its because the rendered images are still 3D and those are the borders of the mesh thus you get your line. If you take a careful look even the previous version of the island demo has these lines on their grass.