Linerenderer view rotation in local space

I have a dotted line that needs to be in local space and be displayed flat above the ground. I’m using a LineRenderer to achieve this. It’s pretty easy to do when the LineRenderer is in world space using the following settings:

  • Alignment: Local

  • Use World Space: True

  • Local Rotation: 90, 0, 0

102179-dottedline.jpg

However, when I use the same settings but change Use World Space to False, the whole line gets rotated by 90° and not just the view.

Changing rotation back to 0° makes the line follow the ground again, but doesn’t make it flat.

102184-dottedline3.jpg

How would I go about displaying the dotted line flat above the ground, but using local space?

I just had the same problem. Could only fix it by rotating the LineRenderer and set the points accordingly. Y is now Z and Z is Y.
I have to say it can be really painful working with that component :confused: