Linux-export: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found

Hi!

I know this is maybe not really a Unity question, or not exclusivly, but maybe one of you have ran into the same problem. I would love to test a linux export on my server. I have a running X session.

When I execute either output2.x86 or output2.x86_64 I receive an error

# ./output2.x86_64
./output2.x86_64: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by ./output2.x86_64)

I figuered this must be due to the server having no suitable graphics card and no graphics accelerated drivers installed. Is this somesthing which will be fixed in the near future? At least that you can run simple scenes which are not very demanding graphically? Or is this already working fine and do I have a different problem, with some important packages not installed or something of that kind?

I run Ubuntu 10.04.4 LTS. Updating to a newer Ubuntu version is unfortunatly not really an option at this point. Any help or comment is appreciated!

Cheers!

You could try installing the OpenGL library, as that is what it looks like is missing. haven’t tested this myself though. But i will give it a shot with my puppy linux distro. (which is apparently based on debian, the same base for Ubuntu) When i have results, i will change this answer.

Hi! So after a long time I figured this out. My old solution was building with Unity below version 4.3 because there seemingly older libraries where supported (EDIT: no, the reason is in Unity 4.3 they reduced the linux player size probably by refering to functions in libstdc++6 rather than delivering them in the player application itsself). From Unity 4.3 up you have to have a new version of libstdc++6. Version 6.0.14 is not sufficient anymore, but Ubuntu 10.04 doesn’t let you install newer versions through the normal package installer (at least not by default).

After hours of searching (several times last months and today) I found this post http://frozenbyte.com/board/viewtopic.php?f=22&t=3427&start=25#p14274 and it solved it for me. Don’t try to install the package with dpkg, as it will fail, but extract the libstdc++6 files and put them in your /usr/lib/ (backup libstdc++.6.so first if you want).

This is vital if you want to run i.e. a headless server on your linux, like i.e. using my package uMMO to create a dedicated authoritative server setup ( Unity Asset Store - The Best Assets for Game Making ). Since Unity 5 you don’t need Unity Pro anymore in order to export to linux “headlessly”.