LINUX : I cannot open my unity project on unityhub that wasn't used to create the project

I reinstalled my OS (I was on Ubuntu 19.10, I formatted my nvme and installed ubuntu 20.04 instead)

pre-emptively I had copied over my unity folder containing the unity hub executable, my downloaded unity version (2020.1.0b2) and my project folder.

On my new OS I ran unity hub, logged in, added the basic license, then located the unity version, which worked.

but when I try to add my previous project there is no file I can select. and If I just select the folder if comes back to unity hub having added nothing.

obviously the versions match because this is the version I downloaded to create this project and I have not downloaded another in the meantime. (It takes over a day for me to download a version so I’m not looking forward to doing that anyday soon).

Why can’t I open my project? What am I supposed to do?
I checked the “Temp” Folder, it’s empty apart for a bin folder which contains a debug folder which is empty. so there is no unityLock file.

hey ; did u select the right folder ?
also if nothing helped delete each foledr except the “Asset”
then rename it to something like “MyOldProject”

now create a new project with unity hub and import the folder into the project;