Loading Asset Bundles on iOS device

I am asking this question again, because nobody answered previous one in Help Room, and I still cant find the solution. Hopefully this time, someone could help me.

I have a problem loading asset bundles from local server or Amazon CDN on Ipad and Iphone, it always return me an error :

The AssetBundle ‘bundleName’ could not be loaded because it is not compatible with this newer version of unity runtime. Rebuild the AssetBundle to fix this error.

I am using Unity 5.6.1p4 , and AssetBundles are loading perfectly in editor, standalone build and Android devices. I am sure asset bundles are built for iOS platform , I am loading bundles using WWW.LoadFromCacheOrDownload() ,and asset bundle version is set higher than previous one.

This problem is bugging me for over a week, and I just cant find any lead,neither anything similar here.

Anyone had this problem before?

Thanks

With the risk of sounding like an ass for stating the obvious, have you actually tried and do what they are suggesting?

The AssetBundle ‘bundleName’ could not
be loaded because it is not compatible
with this newer version of unity
runtime. Rebuild the AssetBundle to
fix this error.

With your current version of Unity (5.6.1p4) select iOS as Platform and make the AssetBundles again. Then delete the old version from the server and upload the new AssetBundle.

@ZeFirestarter Yes, did it too many times, and still gives me the same error.
this problem really gives me an headache.

I’ve finally succeded in loading bundles on device.
The thing was scripting backend was set on Mono2x , and for iOS arm should be set to IL2CPP.