LoadSceneAsync and StartCoroutine still blocks main thread

Hi all,

this has been a pet peeve since day one with Unity and HTCVive, when scenes load, the headset goes to its own loading screen because the unity application stops responding, I see it in almost every application on the market and I guess now I’m seeing why… I have tried and tried and have not managed to make a smooth transition (except between very very small scenes).

It seems to me, that loadasync doesn’t load async at all! because even with a coroutine, while its loading, unity still locks up like it’s busy… failing to keep rendering my active scene, and I do have DontDestroyOnLoad set for the objects in the players immediate view (with their ow fade out transitions)

This worked great when my scene was basic, now that it’s complex and needs to load a few more assets (actually not sure what specifically, I’ve tried removing things one by one, and now that I think of it, it worked when I went to bed, no longer when I woke up…), I get main thread blocking, making it impossible to neatly transition the user.

What should happen (and was working, and I guess still loads… except for the locking for a few seconds)
Is that on selecting a menu item the next scene begins loading, an animation is occuring during this time and only once its done can the user do another action to start(which sets allowSceneActivation to true and lets the transition occur).

Is there any way to ensure the loading really does load asynchronously and not block my main thread? my sounds are already set to ‘load in background’, and I am already using a coroutine. Somone suggested additive scenes but that has the exact same symptom. I have heard asset bundles might be a way to preload the objects that the scene needs, I’ve not used them before though, is that true? any info on this is greatly appreciated, I’m at a total loss as to why it behaves this way

(P.S: Also occurs in release builds, not just the editor, I understand that the editor sometimes lags)

my code looks like so

//this is called first, to begin loading the scene in the background
public void EasyLoadScene(string name) {
	levelname = name;
	isLoading = true;
	StartCoroutine (_load ());
}

//this is the coroutine, which should run in the background
private string levelname = "";
public IEnumerator _load() {
	loading = SceneManager.LoadSceneAsync (levelname, LoadSceneMode.Single);
	loading.allowSceneActivation = false;
}

//this is called once the user is ready for the scene to be activated
public void SwitchSceneNow() {
	if (isLoading) {
		isLoading = false;
		loading.allowSceneActivation = true;
	}
}

I found the calprit… a Spotlight! a disabeld one in fact… I tried recreating the issue in a blank scene for bug report but doesn’t seem to work… maybe I need a more complex scene… anway… that worked for me… removed the spotlight and loading is nice and smooth and async again!

so if you get this issue… it’ll be a specific object causing it. in my case a Spotlight. so check all your lights first