Localization display in IOS not work

Hello everyone I did everything as it is indicated in the documentation for this package, but when assembling the .ipa file from XCode and then installing it on an iPhone, the application name remains the default, what could be the matter? I was also updating Addressable and it seems to me that I still forgot something


Could you also try adding a Short Name value?

Wow, that’s the speed of the response, thank you! Yes, of course) Can you please tell me I’m doing everything right? To localize the application name, I just need to register it in that place and do not need to do any manipulations with Unity and XCode to work?

Settings those values is all you need to do. Then when you build it will set the project files up for you.

1 Like

OK, I added short name and will be doing the build soon, I will unsubscribe soon, thank you!

1 Like

Alas, the customer wrote that the application remains in standard English :frowning:

Have you tested using the iOS simulator? Does it do the same for you?

unfortunately, I do not have iOS devices and I compile using VMware, then I give the build .ipa to the customer and he puts it through windows and iTunes using a wire to his iPhone, this is the sequence) Not use XCode for test

Does the game get built using xcode? The xcode project needs to be generated for the app name localization to work. What language is the user testing with? Are they setting the device language or the app language?

Yes, XCode is used for the assembly, no for subsequent testing, the user is testing in Russian, is it possible to somehow look through the XCode files for the problem? Should something change in info.plist?

There should be a Russian info.plist file.
If the users opens the app options on the iOS device, there should be a list of supported languages.

1 Like

In the XCode build I see an English file, but there is no Russian there, what should I do and how to add it?

There should be files in the xcode project, such as ru/info.plist.
This will contain the values for each language.
Are you using 1.4.2 of the package?

Now, after a new build, I came across such an error after a successful build, maybe it’s because of it


I am using 1.3.2, it is the maximum on my version, apparently


In XCode, only 1 language is visible, English, if it should be displayed here, of course)


It looks like the build script is not running. This script should b executed when you build the iOS player https://github.com/needle-mirror/com.unity.localization/blob/master/Editor/Platform/iOS/BuildPlayerIOS.cs
Can you debug and see if it runs?

This is the only file in the project that I found and it has a representation only in English


Yes, but how do I do it?) I just didn’t really understand what it means to debug a script

It looks like the script is not running. We would need to take a look. Does this reproduce with a new project? Can you please file a bug report?

1 Like