Low resolution texture when imported into Unity

Hi there. In Maya my texture looks like it should, but once I import into Unity the textures turn very low res. I’ve tried to set my texture size to 4096/truecolor but the results are still the same. As a Unity newbie, I’m not sure what to do next :frowning:

My textures are saved as tiff in 4096 resolution

Sometimes the game settings are by default set to something like normal or low - that might be the problem. To have the best quality when you test your game, try to go to “Edit → project settings → quality , then select fantastic / beautiful / whatever is the highest.”
If this doesn’t change anything, you’re using a HUGE texture. 4096, that is really really huge, so maybe unity decrease the quality of your texture, to prevent low fps. Try using something like 1024*1024, unity supports well this quality.