[LWRP] Certain terrain textures look reflective, even though I have turned metallic & smoothness off and specular to black

Note: I am using LWRP terrain shader

I’m making a simple terrain for my game, so I’m in the process of painting the textures on. The problem is, my 2 grass textures and 1 granite texture are reflecting the skybox/main light, even though I turned metallic, smootheness and specular off. All of the other textures are fine, but since they’re my main textures and it looks REALLY weird, it’s a large issue for the moment.

[Link to images] (Imgur: The magic of the Internet “Imgur”)

Also, is there a way to use a material rather than a texture for painting terrain?

I have the same problem. I use Unity3D 2019.2.12f1 Personal edition. The terrain material is Lightweigt Render Pipeline / Terrain / Lit
The only way I have found to turn off the ground reflections is to bring to zero Intensity multiplier in Enviroment Reflection. But this obviously has repercussions on the whole scene

Any suggestions?

Have the same issue, version 2019.2.17f1 - solved by turning reflection to off in the terrain proprieties, as zerograssi said, in detriment to overall scene fidelity.