Mac build closing on start, Windows version works (permissions problem?)

I built a mac version for my game on my mac. The builds have worked in previous iterations, but now when I try and play a build it just immediately closes. When I’m building it though, Unity says the build is successful. The only major difference between now and when the builds worked is that I reinstalled and updated Unity.

This is what the console on my mac says when I try to run my game:

I’ve tried looking up the errors and looking up people with similar problems but nothing seems to be a solution. Anyone have any idea what the problem might be? Any help is greatly appreciated.

Also I made a windows version and I gave it to some friends and they were able to run it fine, if that is any help.

Ok so I made it work. All I did was remove the scenes in Scenes in Build then add them back. Not really sure what it was, but I guess if you reinstall or upload Unity it might be a good idea to do that. Not sure if this has to do with unidentifiable developer problem though.