Mac OS 10.6.4 - Unity won't run

I installed the latest version of Unity on my Mac, OS 10.6.4. Whenever I start Chrome or Safari and try to start my game with Unity, it asks me to download the plugin and restart my browser. I've done all that and Safari is set to 32-bit mode. What should I do?

Thanks in advance!

Hit Command-R. The web player hasn't ever worked properly for me on Snow Leopard; I have to do this almost every time.

You can use Safari in 64-bit mode. Also, 10.6.5 is out; you should update to that. I didn't have any issues with 10.6.4, although it was a slightly customized build that came with recent Mac Pros; not sure if that would make any difference.

Go to "/Libraries/Internet Plug-Ins/" and look for a directory called "Unused". If you see the plugin in there, drag it up one directory to "/Libraries/Internet Plug-Ins/" then delete the "Unused" directory. Reload your browsers and it should work.

I deleted all previous versions of the unity webplayer in /Libraries/Internet Plug-Ins/
and reinstalled it again.
That worked for me.