Mac Ventura update crashes brand new Unity installs

Recently updated my Mac from Monterey to Ventura to comply with Apple's new SDK requirements coming up this month. I didn't use a Time Machine because I wanted to re-install Unity, but not I am completely unable to get unity running.

I installed the latest Unity Editor without issue. It opens up and runs no problem.

However, ANY Unity version I download and install does not work. No matter which one I pick (with or without modules), it crashes when trying to create a new project or open an old one.

The error log is attached below, but it is completely beyond my understanding. Things I've noticed is that

"fatal error: 'metal_types' file not found" is present in almost every script that runs. No idea what Metal is.

"failed assertion 'Render Pipeline Descriptor Validation vertexFunction must not be nil." another potential cause, but Google gives me zero results about this.

I've already tried:
- Restarting the MAC
- Reinstall Unity Editor
- Reinstall Unity LTS version
- Making new projects with different LTS versions
- Tried with/without additional modules

I am completely stumped about this. I can't find any information about this online. If anyone could point me in the right direction it would be incredibly helpful.

Thanks.

8934588--1225107--Editor.txt (212 KB)

I can report the exact same issue on Ventura 13.3.1, on Macbook Pro 11,2. Everything worked very well in Big Sur. Hope this can be addressed urgently by the Unity team, as this is breaking our build pipeline to production.

Edit: Tested on Macbook Pro 2022 M1, both Silicon and Intel work as intended. So this seem to be a problem only on older macs.

@ScuffedCD Which macbook do you have?

I have a Macbook mini 2014. Its actually not supported by Ventura but I was able to use OpenCore Legacy in order to install it.

Turns out you CANNOT manually install more updates via system preferences after using OpenCore. After installing Ventura 3.3, I had went to system preferences and installed the next version (3.4 or something, I forget), which ended up causing loads of issues for my Mac.

On OpenCore's changelog they mentioned some fixes for "Metal". I only use the Mac for converting my builds to XCode, so I don't really know anything about Mac. But my error log kept complaining about Metal so I was able to figure it out.

https://github.com/dortania/OpenCore-Legacy-Patcher/releases
[quote]
With macOS 13.3, Apple broke support for the legacy 3802-based Metal GPUs. With OpenCore Legacy patcher v0.6.2, we've been able to restore support for the following models:

Applicable Models (click to expand)
Note: To restore support for these models, AMFI has to be disabled. If your workflow requires AMFI enabled, we recommend staying on macOS 13.2.1 or older
[/quote]

What I ended up doing was doing a complete reinstall of Ventura to version 3.2.1. At this point I did NOT install any other updates and kept it at this exact version. The changelog for OpenCore had mentioned there were some issues with Metal depending on what version you were on.

However I now have a new issue where I cannot manually install modules for Unity. No idea if this is a related issue or not, but I'm finally at least able to open Unity.

I just installed the Ventura 3.3.1 update on my opencore Mac mini 2014
No issues as far s i can see. More the opposite, that it feels slightly faster,
But i guess that's just the usual update illusion :)
I do not run Unity on the mac mini though, simply use it to build the Xcode project i export from my windows unity installs.

Actually the release 0.6.3 of OpenCore fixes the metal problem we were facing and I didn't have to reinstall the OS, so @spacefrog looks like you downloaded the right version on time :smile:

1 Like