Macbook Pro Retina Display [Solved]

I just got a new computer (as stated above). I am still new to Unity and transfered all my data from my old computer (which is now broken so I cannot get back into it). My problem is when Unity was first opened I noticed on the bottom it said “Rebuilding library because asset database could not be found!” I let it sit there for a bit and recollect the locations. It finished then I went to open the scene I was working on, it opened, kinda.

The scene tab is completely blank and the game tab is an odd colour and nothing from my scene actually shows.

Please oh please someone help! I really do not want to recreate a whole scene.

Update: I started to mess around with the Scene more and it shows everything is there within my Hierarchy…except it is all hott pink. No how in the bloody hell do I make it so it does not all appear hot pink?

Update 2 I connected my old hard drive via a USB to ESATA connection. Yet when I go to open the scene (from the old hard drive) it still said “Rebuilding library because asset database could not be found!” What am I doing wrong. Everything is there except it is all hott pink!?

I had to combine the libraries together even though it was supposed to be an exact replica from Time Machine Backup.

This solved all my problems.

Hope that helps someone else.