MacOS: "Not enough disk space" although there is plenty of it

Every once in a while, I am facing a very weird bug in the Unity Hub. When trying to install a new Editor version, it gets the available disk space completely wrong. I am trying to install the editor for one hour now, freed 60 GB on my drive, but Unity Editor still insists that there would be only 12 GB left. I even uninstalled the previous editor version, hoping that Hub would get at least that change, but still no luck. So I ended up now without any usable Editor. Even a system reboot does not help. Also tried to move the Download folder in the settings, but still no chance to install a new Editor version. What the heck is going on here?!

I just noticed that df -h reports the same lower available disk space (12 GB) for the / mount point, although both Finder and Daisy Disk report almost 70 GB. The problem seems to be caused by Time Machine backups which will be automatically cleared if more space is needed:

https://unix.stackexchange.com/questions/348850/why-df-and-finder-shows-different-available-disk-space

I think Unity Hub should use the "Finder amount" instead of the "df amount". Seems to be a different API.

1 Like