Make directional light not cast shadows of objects behind it

Hello community,

I’m working on a game where you’re playing inside of a huge sphere. I’m using a directional light at the moment, but it is casting shadows from the top of the sphere on the bottom. The directional light follows the player as it moves on the inside of the sphere.

I have made a quick drawing of a sphere with two object on the inside. The blue ball here should cast its shadow on the bottom floor, in the direction of the directional light. This works perfectly fine. However, the green square object also casts shadow on the bottom of the sphere. Disabling the shadow is not an option, because if the player arrives at the green object, there should be a shadow visible.

I know that the position of the direction light is not relevant.
The normals of my sphere are facing towards the inside, which is probably also the reason why my light passes through it.
I have tried using a point light, which is perfect for my game, but the shadows are really bad quality since the light of it has to travel such a huge distance. The same goes for a spotlight.

So, my question is, do you guys have a solution for my problem?
A good solution would be a way to increase the shadow quality of the point light, or to cancel out shadows behind my directional light.

Thank you!

On the renderer component attached to the green square, set “Cast Shadows” to “Off”.