Manifest merger failed issue due to allowBackup

I’m facing this issue when building my Pico VR application:
E:\GitHub\oculus-webview-example\Temp\gradleOut\launcher\src\main\AndroidManifest.xml:44:9-36 Error:
Attribute application@allowBackup value=(false) from [:unityLibrary] AndroidManifest.xml:44:9-36
is also present at [:Pico_PaymentSDK_Android_V1.0.34:] AndroidManifest.xml:18:9-35 value=(true).
Suggestion: add ‘tools:replace=“android:allowBackup”’ to element at AndroidManifest.xml:5:3-154 to override.

If I add ‘tools:replace=“android:allowBackup”’ in the xml file mentioned in the error, then it doesn’t take any effect as all the .xml files in Temp folder are regenerated and the added attribute is removed. There is no manifest file in Assets/Plugins/Android folder. If I paste the xml file mentioned in the error in the Assets/Plugins/Android folder, add 'tools:replace=“android:allowBackup” in it, and then do “Build and Run”, then I get this issue:

DeploymentOperationFailedException: No activity in the manifest with action MAIN and category LAUNCHER. Try launching the application manually on the device.

How do I resolve this issue?


I had the same problem. What you have to do is generate that file, the AndroidManifest.xml file, from Project Seetings → Player → Publishing Setting by clicking the “Custon Main Manifest” option.

Then edit the AndroidManifest.xml file with a text processor that you will find in the Assets\Plugins\Android folder.

And finally add the option tools:replace=“android:allowBackup”