Manually positioned particles disappearing when origin is outside camera view in build only

I am manually setting the positions of particles in a particle system. In the editor, they work as expected. However, when I build to PC and run the built executable, the particles disappear when the origin of the world space (0,0,0) is outside the camera view.

I have read dozens of threads with related problems, but this seems distinct.

I’ve isolated the problem with a test project. Here is the very simple code of the script attached to the object with the particle system:

using UnityEngine;
using System.Collections;

public class ParticleManager : MonoBehaviour {

    ParticleSystem myParticleSystem;
    private int numPoints = 5000;
    private ParticleSystem.Particle[] points;

    // Use this for initialization
    void Start () {
        myParticleSystem = GetComponent<ParticleSystem>();

        points = new ParticleSystem.Particle[numPoints];

        for (int i = 0; i < numPoints; i++) {
            float initialOffset = i * 0.1f;
            //points*.position = new Vector3(initialOffset, 0f, 0f);*

points*.position = new Vector3(Random.Range(-10.0f, 10.0f), Random.Range(-10.0f, 10.0f), Random.Range(-10f, 10f));*
points*.color = new Color(1, 0f, 0f);*
points*.size = 0.1f;*
}
}

* // Update is called once per frame*
* void Update () {*
myParticleSystem.SetParticles(points, points.Length);
}
}

In my scene, there are only two objects, the main camera and the object with the particle system.
The main camera has default settings. I haven’t changed anything there.
The issue is reproducible with these settings for the Particle System (probably with any settings, but I can vouch for these settings for sure as they’re in place as I type this):
Duration: 5
Looping: false
Prewarm: false
Start Delay: 0
Start Lifetime: 0
Start Speed: 0
Start Size : 1
3D Start Rotation: false
Start Rotation: 0
Randomize Rotation Direction: 0
Start Color: 1, 1, 1, 1
Gravity Modifier: 0
Simulation Space: World
Scaling Mode: Local
Play On Awake: false
Max Particles: 1000
All the Particle System nodes are off except for Renderer. The Renderer settings are:
Renderer Mode: Billboard
Normal Direction: 1
Material: Default-Particle
Sort Mode: By Distance
Sorting Fudge: 0
Cast Shadows: off
Receive Shadows: false
Min Particle Size: 0
Max Particle Size: 0.5
Sorting Layer: Default
Order in Layer: 0
Billboard Alignment: View
Pivot: 0, 0, 0
Reflection Probes: off
Also, Resimulate and Wireframe are false
I’ve tried LOTS of things to make this work. I’ve tried setting simulation space to local, turning on resimulate and wireframe, making sure my object transform scale is 1, trying large and small transform scale, trying non-uniform transform scales. It even happens when I set the simulation space to local and parent the particle simulation to be in front of the camera. The particles follow the camera until the world origin is out of view, then they disappear. So, it doesn’t seem to have anything at all to do with the particle system transform. This is not an exclusive list. I’ve tried everything I read in archives, but nothing worked.
And I repeat, this ONLY happens when the game is built, it does not happen at all in the editor.
Can anyone give any suggestions? I’ve run out of ideas at this point and I seem to have exhausted the archives.
This is in Unity 5.3.3f1. I’ve tried it on two separate computers (Windows 8 and 10) and in two separate projects.

We are backporting a fix for Unity Issue Tracker - [Culling] Shuriken is culling particles when we&#39;re using SetParticles, which will be available in 5.3.4p4, which should hopefully fix this issue for you.

Sounds like a bug with culling and the AABB. Can you try the latest version of Unity 5.3.4~
If you still have the problem file a bug report and send me the number so i can take a look.