Mark object do not batch it dynamic

I have a problem.
In my game I’m firing a bullets which are just planes rotated up on camera, and scaled with a distance.
The problem is in scaling, i want to do it using a custom shader (it’s easy to scale in vertex program, just multiplying object space coordinates) BUT! so as i use a prefab on my bullets (same mesh, same material) unity batched it! and so i have a completely different object space coordinates in vertex program

How can I mark object, something like “do not batch” or whatever, so that unity will not batch my bullets.

PLEASE! DO NOT OFFER Me using a transform.localScale, or something like, I want to scale from my shader!

Just tell me, if exist some way I can switch off dynamic batching on objects what i want.

AND DO NOT OFFER Me switch off dynamic batching in player settings.

Sorry to resurrect this thread, but for future wanderers you can do this now per shader by adding “DisableBatching” = “True” to the tags

No, there’s nothing like what you’re asking at present. You’ll have to get creative, like redundantly storing your positions in another vertex attribute.

Why don’t you adjust the material via script. I think dynamic batching requires the use of the property sharedMaterial, and so using the material property will create a copy or something. look it up, it may disable batching.

EDIT: oh wow didn’t realize this thread was so old.