Mask works incorrectly on android device

I am using Unity Mask to mask a image. This is what I get when I run my project in Unity Editor.

The mask is an ellipse and the image is just a webcam texture. When I run the project on iOS device, it is totally fine. And it also works on Galaxy. But when I run this project on a Lenove tablet, it becomes

It is not a ellipse and instead, it becomes the bounding box of the ellipse. The actual mask is the size of the scene with only one white ellipse and transparent background. So the mask is partially working, but it just displays the bounding box instead of the ellipse.

The android version is 5.1.1. My Unity version is 5.4, Personal edition. It works fine on iOS devices and Galaxy phone. Any idea to solve this problem?

Thank You in advance.

Got a similar problem. With the same build the mask works fine on Galaxy S6 (Android 5.1.1) and does not work on Galaxy Tab (Android 6.0.1). It did however work on the Galaxy Tab before with Android 5.1.1. Unity version is 5.4.

I simply use the mask (UI script) and an image with transparency to form the mask.

Any got further information about this? Are there further problems with masks on Android 6.0.1?

This is probably related to the fact that some android devices struggle with "Queue" = "AlphaTest" and clip() in the shaders. Have a look here

If it’s possible, write a custom “UI mask shader”, switching “Queue” = “Transparent”