Massive memory leak in "Not Saved" (Unity 2017.1)

Ok, So I don’t know much about memory, but this seems odd.

I’m currently working on a medium sized project, but the scene setup is very simple. I noticed that, when working on it for a long time, the framerate drops from an initial average of 70-80 fps to about 40-50. So I checked the profiler and found this in the memory section: “Not Saved”, along with “Other”, were both taking up about 4.5 GB of memory. The “Other” seemed OK, but under “Not Saved/Mesh” there was one “Shared UI Mesh” taking up more than 1.5 GB of memory! There were also a bunch of other, empty entries, but those weren’t even remotely that big.

I did some research on this topic, but found nothing useful really. And no, I am not using any plugins like NGUI or MeshBaker. As for setting Text.text, I use it, but not every frame (e.g when player clicks something, you get the idea).

So my question to you is: Does anyone of you also experience this? Have you found a fix for it? Any advice about what i should do to track down the memory leak?

I am using Unity 2017.1.0f3 on Windows 10; 16 GB RAM, SSD, i7 4790k, GTX 1080. I highly doubt my hardware is bottlenecking anything.

I’m looking forward to any sort of answer :wink:

Sorry, image upload not working for me atm.

Edit: It really is some sort of problem with the UI System (I’m using Unity’s new (4.6) UI System). It looks like too many buttons (I used them for inventory slots) causes massive frame drops. With a bunch of buttons etc. I get 40 fps, if I disable all the UI in my game, I get 90+fps. Anyone knowing more about this?

Got the same problem but on iOs

Look at Mesh size after launch


And this is the size after 3 levels( 3 times reloading scene)

Same issue. After bug report Unity Developers promised it will fixed on 2017.2 Stable version…

I had same problem and I’m pretty sure that it’s a bug, When new scene starts I noticed memory leak problem 1 Gb in less of two minutes to be precise. The problem derive from my canvas UI, I deactivated Pixel Perfect checkBox and magically the memory leak is disappeared.

Dowgrading to 5.6.2 fixed it on my side.

The issue is also present on 2017.2.b4

Have same shit and it same can be fixed by downgrading.

Inside my logs each session increase memory (.9Gb → 1.3 → 1.7 → …) and there is no such problem in previouse version.

So, you should wait for updates or downgrade Unity
alt text

Still present in 2017.1.1f1, even though the changelog for the 2017.1 release claims to have fixed this.

This issue haunts us with version 5.4, then 5.5, now in 2017.2 RC

I’ve got the same problem! And uncheck the “Pixel Perfect”, the memory leak in meshes disappeared
Unity Version: 2017.1.0f3