Materials Stretching on Meshes

I would like my materials to not stretch out or in when they’re placed on different sized meshes… when cubes are smaller or stretched, the material stretches with it. It’s set to “Wrap”.

Or, don’t bother with UV mapping but use a custom shader that applies the texture in world-space coordinates rather than texture mapped to the object. This is how triplanar shaders work, for example.

Here is the solution:

  1. Click on your sprite in the Project
  2. In the inspector change the Warp Mode to Repeat

You need a different unique material for each different mesh, or else modify the meshes in a 3D app and set the UVs appropriately, instead of stretching them in Unity.

A little late answer but perhaps helps new ones on the search. Besides setting Wrap mode to Repeat, also click on your material and check the Tilling option.

Its all about the UV mapping here. If you do the UV mapping properly this won’t happen. Each and every texture in the game has to be UV mapped properly so the textures won’t appear to be wearing or tearing.

So i would suggest to take your models back to your modelling software and map them properly.

:slight_smile: :slight_smile: